Узнайте о всех способах поддержки Узнать подробнее

Вики Принт Ф + ШТРИХ-М: Кассир 5 (Розничная торговля 5)

Подписаться
Задать вопрос в службу поддержки
Нужна помощь? Выберите подходящий вам способ связи.
Задать вопрос
Вики Микро
Была ли эта статья полезной?
Пользователи, считающие этот материал полезным: 0 из 0
Еще есть вопросы? Отправить запрос
В начало

Комментарии

Комментариев: 27

  • Выдаётся ошибка при запуске Штрих-М кассир: Не удалось инициализировать фискальный принтер "БПО2.epf"

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    inter-sever

    "Выдаётся ошибка при запуске Штрих-М кассир: Не удалось инициализировать фискальный принтер "БПО2.epf"

    Удалось решить проблему? Хочу попробовать такую схему ПО и ФР.

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Sergey

    "Выдаётся ошибка при запуске Штрих-М кассир: Не удалось инициализировать фискальный принтер "БПО2.epf"
    Удалось решить проблему? Необходимо использовать такую схему

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Владимир

    Евгений, запустите Кассир 5 с правами администратора.

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Sergey

    Проблема, решена. 1С была 8.1 а БПО для 8.2 или 8.3, запуск из 1С 8.3 все решил

    0
    Действия с комментариями Постоянная ссылка
  • У меня в Кассире 5 работают с 3-мя видами оплаты, в обработке их всего 2, как можно добавить в обработку 3 вид оплаты, в кассе прописаны 3 вида. и где можно выставлять ширину ленты, обработку использую и на пиритах под 80 мм, и на ВикиПринтах под 57мм

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Владимир

    Вячеслав, данная обработка распространяется как есть... перекрестной поддержки с компанией Кристалл не получилось (например как с Атол), поэтому поддержка "как есть" на уровне драйвера БПО2.

    На фискальных регистраторах Пирит обработка не тестировалась, но под Вики Принт 80 работает

     

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Alik Alikov

    Также интересует вопрос по оплатам. Три вида оплаты в Кассире, три вида оплаты в кассе (57Ф) . Третий вид оплаты - бонусы, садится на второй вид оплаты. Я так понимаю, проблема в БПО2. Подскажите, какие варианты решения возможны, чтоб бонусы при оплате отдельно учитывать

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    inter-sever

    На сплитах ЕГАИС не печатается QR-код, только текстовая ссылка. ВикиПринт 57Ф версия 559. Что еще нужно настроить еще?

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Вадим

    подскажите в чем проблема

    1
    Действия с комментариями Постоянная ссылка
  • Вадим, Разработчик ПО прокомментировал эту ошибку? Что она означает?

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    inter-sever

    После замены ФН и обновления прошивки (665.0.1) перестала работать касса. Штрих говорит что это проблема драйвера . У вас даже нет лога на который можно положится или выяснить кто виноват.

    0
    Действия с комментариями Постоянная ссылка
  • inter-sever, лога чего? Кассовая программа отправляет и принимает от Вики Принт байтовые последовательности. Разве кассовая программа не ведет логов?

    Наши, например, ведут. И драйвера к 1С ведут логи.

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    inter-sever

     Тогда подскажите где логи формируются? В обработке БПО2 они не указаны, в папке мои документы их тоже нет, в папке где лежит DKViki_1C8-v1.1.0.520.dll то же нет.

    0
    Действия с комментариями Постоянная ссылка
  • inter-sever, логи на новых драйверах пишутся. Лежат тут: C:\Users\USERNAME\Documents\Dreamkas\1C

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    inter-sever

    Долгие изыскания и мучения и никакой информации от тех.поддержки при подключении к Кассир 5.

    Но касса заработала! Если в кассе прошивка от 664 и выше нужен ComProxy 1.2.1, обработка DKViki_1C8-v1.2.0.925.zip, и новая версия от Штриха начиная от 5.1.6.5.

    В Кассире на закладке настройках ККМ выбираем в списке драйвер 1С: БПО2.2 (берем тот что идет в комплекте с дистрибутивом). Настраиваем остальное как в статье выше кроме dll ( dll берём из архива 1.2.0.925) Все настройки в Кассире делаем при запуске программы от имени администратора ( иначе не регистрируются dll). Работа дальше идет в обычном режиме.

    Очень долго намучился с ComProxy 1.3.3 (работал не стабильно, пропадала связь с кассой в 1с в режиме розничных продаж)

     

    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    inter-sever

    Логи появляются только при работе с dll 1.2.0.925. Но там черт ногу сломает. Чем читать для решения проблем?

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    mks2011

    Здравствуйте, подскажите. Сумма в денежном ящике 999999999.0 , везде уже поставили галочки с автоинкосацией и в штрихе и в фито, и записали в ккм ,и поставили галочку не копить денежные средства в ящике в фито .. Ощущение , что проблема с драйвером  dll … Помогите

    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    Игорь

    Добрый день! Проблема не только с суммой в денежном ящике, но и с нумерацией чеков! Номер чека всегда 9999 в кассире в транзакциях, и это действительно проблема. Очень прошу разработчиков решить проблему. На версии БПО 2 проблем с нумерацией нет, но сумма в ящике тоже не отображается.

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Dyusha_Metelkin

    кассир 5 с подпиской, дримкас ключ активирован, драйвер 1.4.2.6. 

    Маркированный, акцизный, но букву М не печатает

    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    Игорь

    кассир 5 с подпиской, дримкас ключ активирован, драйвер 1.4.2.6. 

    Маркированный, акцизный, но букву М не печатает

     

    Бьюсь  над проблемой несколько дней, буква [М] на чеке есть, но в ОФД тег  1162 не передается!

    Поддержка Дримкас требует логи Штрих кассир, поддержка Штрих говорит проблема в ККТ, обращайтесь к разработчику ККТ, и все. Решения нет.

    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    Игорь

    Используем ПО Кассир 5 версии 5.1.7.6 с активированным полным функционалом, ККТ ViKi Print 57Ф с актуальной прошивкой и активированной лицензией на работу с маркированной продукцией. ККТ подключена через БПО 2.2 с помощью компоненты 1.4.2.6

    1
    Действия с комментариями Постоянная ссылка
  • Avatar
    Dyusha_Metelkin

    в офд передается

    Признак предмета расчета

    ТОВАР

    Хотя в карточке стоит маркированный и акцизный.

    Настройки все правильные, по видеоинструкции к Кассиру 5.

    Не пойму почему [M]  не печатается

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Dyusha_Metelkin

    Драйвер 1.4.2.6. Прошивка .... 3.3. Дримкас Ключ активирован. Версия штрих-м последняя, Настройки маркировки все сделаны. Буква м не печатается, тэг в офд не передается, на чеке просто товар...

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    Игорь

    В штрих кассир 5 правим обработку БПО2_2.epf  в основной форме Функция РегистрацияПродажи:

    Было так:

    Функция РегистрацияПродажи(Знач НомерЛУ, Знач БлокСтрок, Знач СуммаПокупки, Знач Количество, Знач Секция, Знач КодНалоговойГруппы, Ошибка, ДопПараметры=Неопределено) Экспорт
    УстановитьТекНомерЛУ(НомерЛУ);
     
    Если НЕ лПодключиться(НомерЛУ) Тогда
    Возврат Ложь;
    КонецЕсли;
     
    ПечатьБлокаСтрок(НомерЛУ, БлокСтрок);
     
    Если Параметры[НомерЛУ]["Фискальный"] Тогда 
     
    Если ДопПараметры = Неопределено Тогда
    ОпОш = "При работе с ОФД минимальная версия протокола работы Кассира с ФР = 1";
    Возврат Ложь;
    КонецЕсли;
     
    тНаименование = " ";
    Если ДопПараметры.Свойство("Наименование", тНаименование) Тогда
    Если тНаименование = "" Тогда
    тНаименование = " ";
    КонецЕсли;
    Иначе
    тНаименование = " ";
    КонецЕсли;
     
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Номер = ТаблицаКоманд.Количество();
    НоваяКоманда.ТипКоманды = 1;
    НоваяКоманда.Text = тНаименование;
    НоваяКоманда.Quantity = Количество;
    НоваяКоманда.PriceWithDiscount = Макс(СуммаПокупки, -СуммаПокупки);
    НоваяКоманда.SumWithDiscount = ОкруглитьСумму(НоваяКоманда.PriceWithDiscount * НоваяКоманда.Quantity);
    НоваяКоманда.Department = Секция; 
    НоваяКоманда.Tax = ПолучитьНомерНалогаВККМ(КодНалоговойГруппы);
     
    Если (КодНалоговойГруппы <> Неопределено) И (КодНалоговойГруппы.Количество() > 0) Тогда
    СтрокаНалога = КодНалоговойГруппы[0];
     
    НоваяКоманда.TaxSum = ОкруглитьСумму(НоваяКоманда.SumWithDiscount * (СтрокаНалога.Ставка / (100 + СтрокаНалога.Ставка)));
     
    НалогВТаблице = НалогиТекущегоЧека.Добавить();
    НалогВТаблице.НалогВККМ = СтрокаНалога.НалогВККМ;
    НалогВТаблице.Сумма = НоваяКоманда.SumWithDiscount;
    НалогВТаблице.СуммаНалога = НоваяКоманда.TaxSum;
    КонецЕсли;
     
    ПризнакПредметаРасчета = 1;
    Если ДопПараметры.Свойство("ПризнакПредметаРасчета", ПризнакПредметаРасчета) Тогда
    Если ПризнакПредметаРасчета = 0 Тогда
    ПризнакПредметаРасчета = 1;
    КонецЕсли;
    Иначе
    ПризнакПредметаРасчета = 1;
    КонецЕсли;
     
    НоваяКоманда.SignCalculationObject = ПризнакПредметаРасчета;
     
    ПризнакСпособаРасчета = 4;
    Если ДопПараметры.Свойство("ПризнакСпособаРасчета", ПризнакСпособаРасчета) Тогда
    Если ПризнакСпособаРасчета = 0 Тогда
    ПризнакСпособаРасчета = 4;
    КонецЕсли;
    Иначе
    ПризнакСпособаРасчета = 4;
    КонецЕсли;
     
    НоваяКоманда.SignMethodCalculation = ПризнакСпособаРасчета;
     
    Если ДопПараметры.Свойство("НаименованиеПоставщика") И Не ПустаяСтрока(ДопПараметры.НаименованиеПоставщика) Тогда
    ТипАгента = 32;
     
    Если ДопПараметры.Свойство("ТипАгента") И ЗначениеЗаполнено(ДопПараметры.ТипАгента) Тогда
    ТипАгента = ДопПараметры.ТипАгента;
    КонецЕсли; 
     
    НоваяКоманда.SignSubjectCalculationAgent = ПолучитьНомерАгента(ТипАгента);
    НоваяКоманда.PurveyorData = Новый Структура("PurveyorName, PurveyorVATIN, PurveyorPhone",
    ДопПараметры.НаименованиеПоставщика, СокрП(ДопПараметры.ИННПоставщика), ДопПараметры.ТелефонПоставщика);
    Иначе
    НоваяКоманда.SignSubjectCalculationAgent = -1;
    КонецЕсли;
     
    Если ДопПараметры.Свойство("ГТД") И Не ПустаяСтрока(ДопПараметры.ГТД) Тогда
    НоваяКоманда.CountryOfOrigin = ДопПараметры.КодСтраныПроисхождения;
    НоваяКоманда.CustomsDeclaration = ДопПараметры.ГТД;
    КонецЕсли;
     
    Если ДопПараметры.Свойство("NewMarkingType") Тогда
    ПервыеДваБайта = ДопПараметры.NewMarkingType;
    Иначе
    ПервыеДваБайта = "";
    КонецЕсли;
     
    Если НЕ ПустаяСтрока(ПервыеДваБайта) Тогда
    GoodCodeData = Неопределено;
     
    ПараметрыМаркировки = Новый Структура("MarkingType, GTIN, SerialNumber, Mark, MarkTagValue", "", "", "", "", "");
    ЗаполнитьЗначенияСвойств(ПараметрыМаркировки, ДопПараметры);
     
    Если ВерсияТребований <= 3001 Тогда
     
    StampType = ПараметрыМаркировки.MarkingType;
    Если Лев(StampType, 2) = "00" Тогда
    StampType = Сред(StampType, 3);
    КонецЕсли;
     
    Если ВерсияТребований = 3001 Тогда
    // StampType в 3.1:
    // 1Изделия из меха
    // 2Табачная продукция
    // 3Обувные товары
    Если StampType = "02" Тогда
    StampType = "1";
    ИначеЕсли StampType = "05" Тогда
    StampType = "2";
    ИначеЕсли StampType = "1520" Тогда
    StampType = "3";
    Иначе
    StampType = "";
    ПервыеДваБайта = "";
    КонецЕсли;
    КонецЕсли;
     
    Если ПервыеДваБайта = "444D" Тогда 
    Если НЕ ПустаяСтрока(ПараметрыМаркировки.MarkingType) 
    И НЕ ПустаяСтрока(ПараметрыМаркировки.GTIN) 
    И НЕ ПустаяСтрока(ПараметрыМаркировки.SerialNumber) Тогда
     
    GoodCodeData = Новый Структура("StampType, Stamp, GTIN, SerialNumber", "", "", "", "");
    GoodCodeData.StampType = StampType;
    GoodCodeData.GTIN = ПараметрыМаркировки.GTIN;
    GoodCodeData.SerialNumber = ПараметрыМаркировки.SerialNumber;
     
    КонецЕсли;
    ИначеЕсли ПервыеДваБайта = "5246" Тогда
     
    Если НЕ ПустаяСтрока(ПараметрыМаркировки.Mark) Тогда
    GoodCodeData = Новый Структура("StampType, Stamp, GTIN, SerialNumber", "", "", "", "");
    GoodCodeData.StampType = StampType; 
    GoodCodeData.Stamp = ПараметрыМаркировки.Mark; // КИЗ 
    КонецЕсли;
     
    КонецЕсли;
     
    Иначе
    //3002+
    Если НЕ ПустаяСтрока(ПараметрыМаркировки.MarkTagValue) Тогда
    ЗначениеТэга1162 = HEXStrToBase64(ПараметрыМаркировки.MarkTagValue);
    Если НЕ ПустаяСтрока(ЗначениеТэга1162) Тогда
    GoodCodeData = Новый Структура("MarkingCode", ЗначениеТэга1162);
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
     
    Если GoodCodeData <> Неопределено Тогда
    НоваяКоманда.GoodCodeData = GoodCodeData;
    КонецЕсли;
    КонецЕсли;
     
    Иначе
    // нефискальный чек, печатает цену, количество сами
     
    Если ДопПараметры = Неопределено Тогда
    // сюда можем попасть при печати копии чека, регистрации по позициям уже выполнились
    Возврат Истина;
    КонецЕсли;
     
    тНаименование = " ";
    Если ДопПараметры.Свойство("Наименование", тНаименование) Тогда
    Если тНаименование = "" Тогда
    тНаименование = " ";
    КонецЕсли;
    Иначе
    тНаименование = " ";
    КонецЕсли;
     
    Quantity = Количество;
     
     
    Если НЕ ПустаяСтрока(тНаименование) Тогда 
    ПечатьСтроки(тНаименование);
    КонецЕсли;
     
    //TaxTypeNumber = ПолучитьНомерНалогаВККМ(КодНалоговойГруппы);
    СтрокаСекция = " " + Формат(Секция, "ЧЦ=2; ЧН=; ЧВН=");
    СтрокаЦенаКоличество = Формат(Количество, "ЧДЦ=3; ЧРД=.; ЧН=") 
    + " X " 
    + Формат(СуммаПокупки, "ЧДЦ=2; ЧРД=.; ЧН=") 
    + "  " 
    + Формат(ОкруглитьСумму(Количество * СуммаПокупки), "ЧДЦ=2; ЧРД=.; ЧН=");
     
    СтрокаРегистрации = ДополнитьСтрокуСправа(СтрокаСекция, ШиринаЛенты - СтрДлина(СтрокаЦенаКоличество), " ") + СтрокаЦенаКоличество;
    ПечатьСтроки(СтрокаРегистрации);
     
    КонецЕсли;
     
    Параметры[НомерЛУ]["ЧекОткрыт"] = Истина;
     
    Возврат Истина;
    КонецФункции
     
     
     

    Сделал так:

    Функция РегистрацияПродажи(Знач НомерЛУ, Знач БлокСтрок, Знач СуммаПокупки, Знач Количество, Знач Секция, Знач КодНалоговойГруппы, Ошибка, ДопПараметры=Неопределено) Экспорт
    УстановитьТекНомерЛУ(НомерЛУ);
     
    Если НЕ лПодключиться(НомерЛУ) Тогда
    Возврат Ложь;
    КонецЕсли;
     
    ПечатьБлокаСтрок(НомерЛУ, БлокСтрок);
     
    Если Параметры[НомерЛУ]["Фискальный"] Тогда 
     
    Если ДопПараметры = Неопределено Тогда
    ОпОш = "При работе с ОФД минимальная версия протокола работы Кассира с ФР = 1";
    Возврат Ложь;
    КонецЕсли;
     
    тНаименование = " ";
    Если ДопПараметры.Свойство("Наименование", тНаименование) Тогда
    Если тНаименование = "" Тогда
    тНаименование = " ";
    КонецЕсли;
    Иначе
    тНаименование = " ";
    КонецЕсли;
     
    НоваяКоманда = ТаблицаКоманд.Добавить();
    НоваяКоманда.Номер = ТаблицаКоманд.Количество();
    НоваяКоманда.ТипКоманды = 1;
    НоваяКоманда.Text = тНаименование;
    НоваяКоманда.Quantity = Количество;
    НоваяКоманда.PriceWithDiscount = Макс(СуммаПокупки, -СуммаПокупки);
    НоваяКоманда.SumWithDiscount = ОкруглитьСумму(НоваяКоманда.PriceWithDiscount * НоваяКоманда.Quantity);
    НоваяКоманда.Department = Секция; 
    НоваяКоманда.Tax = ПолучитьНомерНалогаВККМ(КодНалоговойГруппы);
     
    Если (КодНалоговойГруппы <> Неопределено) И (КодНалоговойГруппы.Количество() > 0) Тогда
    СтрокаНалога = КодНалоговойГруппы[0];
     
    НоваяКоманда.TaxSum = ОкруглитьСумму(НоваяКоманда.SumWithDiscount * (СтрокаНалога.Ставка / (100 + СтрокаНалога.Ставка)));
     
    НалогВТаблице = НалогиТекущегоЧека.Добавить();
    НалогВТаблице.НалогВККМ = СтрокаНалога.НалогВККМ;
    НалогВТаблице.Сумма = НоваяКоманда.SumWithDiscount;
    НалогВТаблице.СуммаНалога = НоваяКоманда.TaxSum;
    КонецЕсли;
     
    ПризнакПредметаРасчета = 1;
    Если ДопПараметры.Свойство("ПризнакПредметаРасчета", ПризнакПредметаРасчета) Тогда
    Если ПризнакПредметаРасчета = 0 Тогда
    ПризнакПредметаРасчета = 1;
    КонецЕсли;
    Иначе
    ПризнакПредметаРасчета = 1;
    КонецЕсли;
     
    НоваяКоманда.SignCalculationObject = ПризнакПредметаРасчета;
     
    ПризнакСпособаРасчета = 4;
    Если ДопПараметры.Свойство("ПризнакСпособаРасчета", ПризнакСпособаРасчета) Тогда
    Если ПризнакСпособаРасчета = 0 Тогда
    ПризнакСпособаРасчета = 4;
    КонецЕсли;
    Иначе
    ПризнакСпособаРасчета = 4;
    КонецЕсли;
     
    НоваяКоманда.SignMethodCalculation = ПризнакСпособаРасчета;
     
    Если ДопПараметры.Свойство("НаименованиеПоставщика") И Не ПустаяСтрока(ДопПараметры.НаименованиеПоставщика) Тогда
    ТипАгента = 32;
     
    Если ДопПараметры.Свойство("ТипАгента") И ЗначениеЗаполнено(ДопПараметры.ТипАгента) Тогда
    ТипАгента = ДопПараметры.ТипАгента;
    КонецЕсли; 
     
    НоваяКоманда.SignSubjectCalculationAgent = ПолучитьНомерАгента(ТипАгента);
    НоваяКоманда.PurveyorData = Новый Структура("PurveyorName, PurveyorVATIN, PurveyorPhone",
    ДопПараметры.НаименованиеПоставщика, СокрП(ДопПараметры.ИННПоставщика), ДопПараметры.ТелефонПоставщика);
    Иначе
    НоваяКоманда.SignSubjectCalculationAgent = -1;
    КонецЕсли;
     
    Если ДопПараметры.Свойство("ГТД") И Не ПустаяСтрока(ДопПараметры.ГТД) Тогда
    НоваяКоманда.CountryOfOrigin = ДопПараметры.КодСтраныПроисхождения;
    НоваяКоманда.CustomsDeclaration = ДопПараметры.ГТД;
    КонецЕсли;
     
    Если ДопПараметры.Свойство("NewMarkingType") Тогда
    ПервыеДваБайта = ДопПараметры.NewMarkingType;
    Иначе
    ПервыеДваБайта = "";
    КонецЕсли;
     
    Если НЕ ПустаяСтрока(ПервыеДваБайта) Тогда
    GoodCodeData = Неопределено;
     
    ПараметрыМаркировки = Новый Структура("MarkingType, GTIN, SerialNumber, Mark, MarkTagValue", "", "", "", "", "");
    ЗаполнитьЗначенияСвойств(ПараметрыМаркировки, ДопПараметры);
     
    //3002+
    Если НЕ ПустаяСтрока(ПараметрыМаркировки.MarkTagValue) Тогда
    ЗначениеТэга1162 = HEXStrToBase64(ПараметрыМаркировки.MarkTagValue);
    Если НЕ ПустаяСтрока(ЗначениеТэга1162) Тогда
    GoodCodeData = Новый Структура("MarkingCode", ЗначениеТэга1162);
    КонецЕсли;
    КонецЕсли;
     
    Если GoodCodeData <> Неопределено Тогда
    НоваяКоманда.GoodCodeData = GoodCodeData;
    КонецЕсли;
    КонецЕсли;
     
    Иначе
    // нефискальный чек, печатает цену, количество сами
     
    Если ДопПараметры = Неопределено Тогда
    // сюда можем попасть при печати копии чека, регистрации по позициям уже выполнились
    Возврат Истина;
    КонецЕсли;
     
    тНаименование = " ";
    Если ДопПараметры.Свойство("Наименование", тНаименование) Тогда
    Если тНаименование = "" Тогда
    тНаименование = " ";
    КонецЕсли;
    Иначе
    тНаименование = " ";
    КонецЕсли;
     
    Quantity = Количество;
     
     
    Если НЕ ПустаяСтрока(тНаименование) Тогда 
    ПечатьСтроки(тНаименование);
    КонецЕсли;
     
    //TaxTypeNumber = ПолучитьНомерНалогаВККМ(КодНалоговойГруппы);
    СтрокаСекция = " " + Формат(Секция, "ЧЦ=2; ЧН=; ЧВН=");
    СтрокаЦенаКоличество = Формат(Количество, "ЧДЦ=3; ЧРД=.; ЧН=") 
    + " X " 
    + Формат(СуммаПокупки, "ЧДЦ=2; ЧРД=.; ЧН=") 
    + "  " 
    + Формат(ОкруглитьСумму(Количество * СуммаПокупки), "ЧДЦ=2; ЧРД=.; ЧН=");
     
    СтрокаРегистрации = ДополнитьСтрокуСправа(СтрокаСекция, ШиринаЛенты - СтрДлина(СтрокаЦенаКоличество), " ") + СтрокаЦенаКоличество;
    ПечатьСтроки(СтрокаРегистрации);
     
    КонецЕсли;
     
    Параметры[НомерЛУ]["ЧекОткрыт"] = Истина;
     
    Возврат Истина;
    КонецФункции

    Это простой костыль, в драйвер должен передаваться MarkingCode. Кассир 5 получает версию требований стандарта 1С БПО (версия 2.5, 3.1, 3.2 и т.п.) из загруженного драйвера ККМ (ф-я GetInterfaceRevision).
    Если полученная версия:
    младше 3.1 - передаются StampType, GTIN, SerialNumber
    3.1 - аналогично версиям меньше 3.1, только изменены значения типов маркировок StampType
    старше 3.1 - передаётся MarkingCode.

    Драйвер Дримкас возвращает 2.5 (2005). Обратите внимание, не заморачивался с признаком предмета расчета, некогда, пока тоже передается товар но марки успешно выводятся из оборота.

    Очень надеюсь, что разработчики кассир 5 и Дримкас общими усилиями решат проблемы.  

    0
    Действия с комментариями Постоянная ссылка
  • Avatar
    oleg karpov

    Драйвер 1.4.2.6. Прошивка 665.3.3. Дримкас Ключ активирован. Версия штрих-м последняя, Настройки маркировки все сделаны. Буква м не печатается, тэг в офд не передается.

    2
    Действия с комментариями Постоянная ссылка
  • Avatar
    Dyusha_Metelkin

    Заработала маркировка с помощью обработки из штриховской инструкции: https://kkm.solutions/wiki/doku.php?id=вопросы:подключение_ккм_википринт

    Буква [M] на чеке появилась, тэг стал корректно передаваться.

    Поправьте шапку, а то там неработающая epf-ка.

    0
    Действия с комментариями Постоянная ссылка

Войдите в службу, чтобы оставить комментарий.

На базе технологии Zendesk